Check out the new API Notebook!


#1

Hey y’all, the new API Notebook site is up. Whaddya think?

p.s.: If it’s easier to remember, you can go to apinotebook.com and get redirected there.


#2

This topic is now pinned. It will appear at the top of its category until it is either unpinned by a moderator, or the Clear Pin button is pressed.


#3

The API Notebook is awesome!


#4

Thanks, Matt! How are you using it? What’s your favorite (and least favorite) part?

//Dillon


#5

Hi Guys,

I know it’s a stupid question but - how can I actually run the api-notebook? Should it be included in another application? What application can I embed it in? Can it be run as a standalone application?

Thank you!

Cheers
Igor


#6

You run it right from your browser: on every notebook, there is a run button, or you can click the run button on any cell and all cells up to and including that one will run. You can also embed the notebook in any web page using the script tag visible when you click the share button. And if you have our you create a web page that has the notebook embedded in it, you can run that I your browser from your desktop. Finally, the notebook code is all available from github, with instructions.

Note that there there’s the notebook site, which shows instructions and your list of notebooks; and then there’s the notebook itself, embedded in it or in any other Web page.


#7

Hi @usarid,

thanks for the explanation. I probably wasn’t specific enough. I cloned the git repository and ran ‘npm install’. Everything seemed fine. I tried to run ‘grunt server’ to start the application but got the response from the notebook that there is now ‘server’ task inside Gruntfile.js.
I ran just ‘grunt’ then and the notebook seemed to start on http://localhost:3000 but when I navigate to this URL I get ‘Connection could not be established’.
Unfortunately the instructions on the github page don’t say a lot.

Cheers
Igor


#8

Hi @usarid,

it seems like the api-notebook is running on localhost and can only be accessed via the browser that’s runnig on the same machine. Is it possible to change this setting to 0.0.0.0 somewhere, so that I can reach the notebook from “outside”. Unfortunately I couldn’t find this setting anywhere.

Thank you very much!

Cheers
Igor


#9

Hi @igor_kosta,
The team has been working here and pushed a fix for this.

Please, feel free to try and let me know how it goes!

Cheers!


#10

Hi @nohorbee,

first of all, thank you very much for this quick fix.
Unfortunately I couldn’t get it to work yet. The server and the app start and I can navigate to http://0.0.0.0:3000 but the only thing I see is a blank page although .icn is loaded properly.
P.S. there are currently three javascript errors on the page (see attached screenshot)


Cheers
Igor


#11

Am I really the only one having these issues? What am I doing wrong?

Any help greatly appreciated!


#12

hi @igor_kosta,

The original notebook dev is in town this week and next - I’ve asked him to take a look here and respond to this thread with his findings.

Sorry for the delay, hopefully we can help resolve this soon now.

//Dillon


#13

@igor_kosta Did you want to try it again now? I just fixed the issue when the proxy url was not defined in configuration. I’ll try to find time over the next few weeks to improve documentation and onboarding.


#14

Hi @blakeembrey,

now it seems to start properly. I didn’t have time to test if everything is working as expected.

Thank you very much for the fix!

I’ll let you know if I’ll found another issue!

Keep up the good work!

Cheers
Igor


#15

API notebook is indeed awesome https://api-notebook.anypoint.mulesoft.com/notebooks
Looking for some GitHub link to run it in localhost


#16